Elia Pinto <gitter.spi...@gmail.com> writes:

> This is the second version of this patch.  It had not been
> discussed before. In the second version, I just tried to clarify
> the comment in the commit. I resend it just in case you missed

I do not recall seeing it before.  No discussion usually means no
interest, so I'll see what happens this time on the list for a few
days before picking it up.

> +#if SUPPORT__BUILTIN_TYPES_COMPATIBLE_P
> +/* &arr[0] degrades to a pointer: a different type from an array */
> +#define _array_size_chk(arr)                                         \
> +     BUILD_ASSERT_OR_ZERO(!__builtin_types_compatible_p(typeof(arr), \
> +                                                     typeof(&(arr)[0])))
> +#else
> +#define _array_size_chk(arr) 0
> +#endif

Wouldn't there be a more sensible name?  _chk does not tell us
anything about what is being checked, and the only thing this name
gives us is "what uses it" (i.e. it is some magic used by array-size
and does not say what it checks and what for).

I think you are checking arr is an array and not a pointer.  Perhaps
"#define is_an_array(arr)" or something along that line may be a
more descriptive name for it.

I doubt the leading underscore is particularly a good idea, though.

> +/*
> + * ARRAY_SIZE - get the number of elements in a visible array
> + *  <at> x: the array whose size you want.
> + *
> + * This does not work on pointers, or arrays declared as [], or
> + * function parameters.  With correct compiler support, such usage
> + * will cause a build error (see build_assert).
> + */
> +#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]) + _array_size_chk(x))
>  #define bitsizeof(x)  (CHAR_BIT * sizeof(x))
>  
>  #define maximum_signed_value_of_type(a) \
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to