This is a re-roll of the series at:

  http://thread.gmane.org/gmane.comp.version-control.git/268185

The only changes here are the addition of patches 2 and 6, which are
both cleanups that help make the other patches more readable/sensible.
They are the same as what was posted during review of the thread linked
above.  So there's nothing new here, but of course fresh reviews are
welcome.

  [01/14]: remote.c: drop default_remote_name variable
  [02/14]: remote.c: refactor setup of branch->merge list
  [03/14]: remote.c: drop "remote" pointer from "struct branch"
  [04/14]: remote.c: hoist branch.*.remote lookup out of remote_get_1
  [05/14]: remote.c: provide per-branch pushremote name
  [06/14]: remote.c: hoist read_config into remote_get_1
  [07/14]: remote.c: introduce branch_get_upstream helper
  [08/14]: remote.c: report specific errors from branch_get_upstream
  [09/14]: remote.c: add branch_get_push
  [10/14]: sha1_name: refactor upstream_mark
  [11/14]: sha1_name: refactor interpret_upstream_mark
  [12/14]: sha1_name: implement @{push} shorthand
  [13/14]: for-each-ref: use skip_prefix instead of starts_with
  [14/14]: for-each-ref: accept "%(push)" format

-Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to