David Aguilar <dav...@gmail.com> writes:

> -     if (! -f "$workdir/$file") {
> -             return (0, $null_sha1);
> +     my $workfile = "$workdir/$file";
> +     if (-f $workfile && ! -l $workfile) {

I still don't know if return (0, $null) is the right thing to do,
but in any case, I find the original flow easier to read, i.e. "we
notice a few cases we cannot do the main 'hash-object' thing this
function is meant to do and return early".  I.e.

        if (-l "$workdir/$file" || ! -f _) {
                return (0, $null_sha1);
        }
        my $wt_sha1 = $repo->command_oneline('hash-object', "$workdir/$file");
        my $use = ($sha1 eq $null_sha1) || ($sha1 eq $wt_sha1);
        return ($use, $wt_sha1);
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to