Hi, gophers!

Idk if this has been proposed or discussed before.

Given the last error handling abbreviation proposal is rejected. How about 
some simple syntactic sugar like this:

  *rin* Something()

Which is just a sugar for:

  if err := Something(); err != nil {
    return err
  }

To make it worth the new keyword make it so that:

  *rin* v := Something()

equals to:

  v, err := Something()
  if err != nil {
    return err
  }

-- 
You received this message because you are subscribed to the Google Groups 
"golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to golang-nuts+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/golang-nuts/955d78f2-67cb-4940-845c-034fb45e816an%40googlegroups.com.

Reply via email to