Overall, this widget looks very cool.  <ake sure you apply the GWT check
styles as they show a few problems, such as missing periods, unnecessary
casts, unused @param tags, and unresolved types used in JavaDoc.  There are
a lot of methods with partial JavaDoc as well.

Most of my suggestions are minor, but I think the CalendarModel exposes too
many methods that aren't really specific to the model itself.  To me, it
makes sense to hide the implementation details instead of opening up static
methods.

CalendarModel:
Most of the static methods in CalendarModel seem like implementation details
that should not be exposed.
- computeYearBeforeMonth() should be renamed, removed, or made package
protected since it is really an implementation detail.  I vote for removing
it.
- copy() could be renamed to copyDate()
- diffDays could be renamed to calculateInterval or something else.  Should
specify if start and/or end is inclusive.
- createKeyFromDate seems like an implementation detail.  Also, it says it
will create a unique string key for the date, but only if the dates are
unique by day.  If two dates have the same days (even if they have different
times), the key will be the same.

DatePickerComponent
- Needs JavaDoc

DatePicker
324: I don't think you should fire the showRangeEvent retroactively, its not
consistent with other handlers and doesn't really make sense logically that
the event is fired when you add a handler.
426: why not just use a while loop instead of a for loop?
446: when you set the allowable date range, you should probably check that
the current date is within that range

Thanks,
John LaBanca
[EMAIL PROTECTED]


On Mon, Sep 29, 2008 at 1:27 PM, Emily Crutcher <[EMAIL PROTECTED]> wrote:

> Could you review the gen 2 date picker code? The code is in
> com.google.gwt.gen2.datepicker. This code is going to be moved over to gwt
> after the handler code is moved, so nitpicks would be very welcome.
>
>      thanks!
>
>                    Emily
>
> --
> "There are only 10 types of people in the world: Those who understand
> binary, and those who don't"
>

--~--~---------~--~----~------------~-------~--~----~
http://groups.google.com/group/Google-Web-Toolkit-Contributors
-~----------~----~----~----~------~----~------~--~---

Reply via email to