LGTM with nits

http://gwt-code-reviews.appspot.com/605801/diff/1/2
File /bikeshed/src/com/google/gwt/collections/Assertions.java (right):

http://gwt-code-reviews.appspot.com/605801/diff/1/2#newcode24
/bikeshed/src/com/google/gwt/collections/Assertions.java:24: *
Needs comment

http://gwt-code-reviews.appspot.com/605801/diff/1/5
File /bikeshed/src/com/google/gwt/collections/MutableArray.java (right):

http://gwt-code-reviews.appspot.com/605801/diff/1/5#newcode25
/bikeshed/src/com/google/gwt/collections/MutableArray.java:25: public
class MutableArray<E> extends Array<E> {
Would it make more sense to declare the whole class final?

http://gwt-code-reviews.appspot.com/605801/diff/1/5#newcode52
/bikeshed/src/com/google/gwt/collections/MutableArray.java:52: * Creates
an immutable array based on this one. Also marks this object as
read-only.
line wrap

http://gwt-code-reviews.appspot.com/605801/diff/1/7
File
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/CollectionFactory.java
(right):

http://gwt-code-reviews.appspot.com/605801/diff/1/7#newcode21
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/CollectionFactory.java:21:
* Made to be switched out using super source even while Collections
itself isn't.
line wrap

http://gwt-code-reviews.appspot.com/605801/diff/1/7#newcode24
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/CollectionFactory.java:24:

doc

http://gwt-code-reviews.appspot.com/605801/diff/1/7#newcode28
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/CollectionFactory.java:28:

doc

http://gwt-code-reviews.appspot.com/605801/diff/1/7#newcode34
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/CollectionFactory.java:34:

doc

http://gwt-code-reviews.appspot.com/605801/diff/1/11
File
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java
(right):

http://gwt-code-reviews.appspot.com/605801/diff/1/11#newcode24
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java:24:
public class MutableArray<E> extends Array<E> {
Mark class as final rather than each method?

http://gwt-code-reviews.appspot.com/605801/diff/1/11#newcode46
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java:46:
* read-only. After calling {...@code freeze()}, only use methods from
Something is wrong with the text here, looks like different pieces got
pasted together ungrammatically.

http://gwt-code-reviews.appspot.com/605801/diff/1/11#newcode56
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java:56:
* Inserts {...@code element} before the element residing at {...@code index}.
element -> elem

http://gwt-code-reviews.appspot.com/605801/diff/1/11#newcode174
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java:174:
var fillStart;
fillstart is unused, remove

http://gwt-code-reviews.appspot.com/605801/diff/1/11#newcode175
/bikeshed/super/com/google/gwt/collections/super/com/google/gwt/collections/MutableArray.java:175:
var i;
Declare 'i' where it is used ('for (var i...')

http://gwt-code-reviews.appspot.com/605801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to