http://gwt-code-reviews.appspot.com/1108801/diff/1/4
File dev/core/src/com/google/gwt/dev/jjs/JavaToJavaScriptCompiler.java
(right):

http://gwt-code-reviews.appspot.com/1108801/diff/1/4#newcode314
dev/core/src/com/google/gwt/dev/jjs/JavaToJavaScriptCompiler.java:314:
JavaToJavaScriptMap jjsmap = GenerateJavaScriptAST.exec(jprogram,
jsProgram,
this is just for readability.  I had a hard time searching around for a
variable named 'map'

http://gwt-code-reviews.appspot.com/1108801/diff/1/9
File dev/core/src/com/google/gwt/dev/util/StringInterner.java (right):

http://gwt-code-reviews.appspot.com/1108801/diff/1/9#newcode52
dev/core/src/com/google/gwt/dev/util/StringInterner.java:52: */
this may not be necessary, but on a large build, I noticed about 5 MB of
references to 1 character strings.  This seemed to be a convenient
shortcut.

http://gwt-code-reviews.appspot.com/1108801/diff/1/9#newcode60
dev/core/src/com/google/gwt/dev/util/StringInterner.java:60: }
I should go back and check - I found many one character identifiers not
being interned and added this code.  As you noticed, I also found that a
setter missing a call which was probably the real culprit.

On 2010/11/15 23:10:20, conroy wrote:
this seems reasonable enough to me--though I wonder if it's really
necessary.

out of curiosity, did you measure how much of a speedup this gave over
the
normal interning call (which is really just a get on a hash map)?

http://gwt-code-reviews.appspot.com/1108801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to