Since the function isn't documented, I'm not sure what its supposed to
return, but it looks to me like  the getQualifiedBinaryName() method
returns the same string in all cases where it is actually used.  It
has a TODO(scottb): remove me... and is rarely used: only in some
error messages and as a key to a data structure in
MethodArgNamesLookup.  I added asserts() to test this in each instance
and they never tripped.

I can refactor one of the implementations out: which implementation do
you prefer?

On Tue, Nov 23, 2010 at 7:31 PM,  <sco...@google.com> wrote:
>
> http://gwt-code-reviews.appspot.com/1144801/diff/6001/7001
> File dev/core/src/com/google/gwt/core/ext/typeinfo/JType.java (right):
>
> http://gwt-code-reviews.appspot.com/1144801/diff/6001/7001#newcode33
> dev/core/src/com/google/gwt/core/ext/typeinfo/JType.java:33: public
> String computeBinaryClassName() {
> So... my comment was going to be to rename this to getBinaryName().
> Then I saw getQualfiedBinaryName(), and I was like... wait, what?
> Shouldn't these basically be the same thing?  Our API makes me cry.
>
> http://gwt-code-reviews.appspot.com/1144801/show
>



-- 
Eric Z. Ayers
Google Web Toolkit, Atlanta, GA USA

-- 
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to