Sorry about the delay. The functionality looks fine but I will quibble with the API a little.
http://gwt-code-reviews.appspot.com/1629803/diff/1/user/src/com/google/gwt/uibinder/rebind/GetEscapedInnerTextVisitor.java File user/src/com/google/gwt/uibinder/rebind/GetEscapedInnerTextVisitor.java (right): http://gwt-code-reviews.appspot.com/1629803/diff/1/user/src/com/google/gwt/uibinder/rebind/GetEscapedInnerTextVisitor.java#newcode26 user/src/com/google/gwt/uibinder/rebind/GetEscapedInnerTextVisitor.java:26: class GetEscapedInnerTextVisitor implements NodeVisitor { Since escaping the inner text is now optional, I think we should rename this to "GetInnerTextVisitor". http://gwt-code-reviews.appspot.com/1629803/diff/1/user/src/com/google/gwt/uibinder/rebind/XMLElement.java File user/src/com/google/gwt/uibinder/rebind/XMLElement.java (right): http://gwt-code-reviews.appspot.com/1629803/diff/1/user/src/com/google/gwt/uibinder/rebind/XMLElement.java#newcode446 user/src/com/google/gwt/uibinder/rebind/XMLElement.java:446: public String consumeInnerTextEscapedAsHtmlStringLiteral(Interpreter<String> interpreter, On 2012/02/10 23:30:59, iteratee wrote:
On 2012/02/10 21:09:08, rdayal wrote: > This method name is somewhat confusing now - > "consumeInnerTextEscapedAsHtmlStringLiteral" - does that name still
apply even
> if html entities are not escaped?
The terminology is confusing because 2 kinds of escaping are
occurring. Java
String escaping, and (possibly) html escaping.
I think the name is still fitting.
I think I agree with Rajeev. This API is rather confusing. I would rather see two public methods: consumeInnerTextEscapedAsHtmlStringLiteral(interpreter); consumeInnerTextTrimmed(interpreter); Internally, they could call the same private method with a boolean if that's how you want to do it, but that shouldn't be exposed in the API. http://gwt-code-reviews.appspot.com/1629803/ -- http://groups.google.com/group/Google-Web-Toolkit-Contributors