Hi,
I'm migrating a library from gwt 1.5.2 to 2.0.
I had a class extending PopupPanel that implemented SourcesTreeEvents
(well, don't care about the reasons).

Now that I must convert that to the new interfaces, I try to od it in
the most straightforward way.

But that would be replacing SourcesTreeEvents with
HasSelectionHandler<TreeImte>&HasOpenEvent<TreeItem>&HasCloseEvent<TreeItem>.

Now, as PopupPanel implements HasCloseListener<PopupPanel>, I have a
problem.

There would be a conflict between addCloseHandler(PopupPanel) and
addCloseHandler(TreeItem). Classical misconception of the java
language here (erasures and all).

What the good way here ? rename addCloseHandler(TreeItem) to some
other name and forget about HasCloseEvent ?

-- 
You received this message because you are subscribed to the Google Groups 
"Google Web Toolkit" group.
To post to this group, send email to google-web-tool...@googlegroups.com.
To unsubscribe from this group, send email to 
google-web-toolkit+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/google-web-toolkit?hl=en.

Reply via email to