Why the GWT team decided to name the interface for a view Display?
IMHO View would be a better choice. This would turn the Contact
example into something like this:

public class ContactsPresenter implements Presenter {

  public interface View {
    // methods
  }

}

public class ContactsView extends Composite implements
ContactsPresenter.View {
}

One less word in the vocabulary of GWT, and if I am not wrong, one
less deviation from the original applications of the MVP pattern.

-- 
You received this message because you are subscribed to the Google Groups 
"Google Web Toolkit" group.
To post to this group, send email to google-web-toolkit@googlegroups.com.
To unsubscribe from this group, send email to 
google-web-toolkit+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/google-web-toolkit?hl=en.

Reply via email to