Am Montag, den 13.04.2009, 21:11 +0200 schrieb Robert Millan:
> How about [__FreeBSD__ || __FreeBSD_kernel__] ?
Ok.
> > + if (sysctlbyname ("kern.geom.debugflags", &sysctl_oldflags,
> > &sysctl_size, NULL, 0))
> > + grub_util_error ("cannot get current flags of sysctl
> > kern.geom.debugflags");
>
> I'd just return grub_error instead. Otherwise we abort the program even if
> failure to read a drive is not critical (e.g. lvm.mod scannning all drives,
> grub-emu, etc).
Ok.
> > + if (! sysctl_oldflags & 0x10 && sysctlbyname ("kern.geom.debugflags",
> > NULL , 0, &sysctl_flags, sysctl_size))
> > + grub_util_error ("cannot set flags of sysctl kern.geom.debugflags");
>
> Just a matter of taste, I'd suggest nested ifs to make it more readable.
Changed too.
I commited this now.
--
Felix Zielcke
_______________________________________________
Grub-devel mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/grub-devel