ChangeLog:
* boot/i386/pc/boot.S (general_error_string): Add DOS newline at
the end of "Error" to make the message more readable in qemu.
---
boot/i386/pc/boot.S | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/boot/i386/pc/boot.S b/boot/i386/pc/boot.S
index 9323cb9..e3f5228 100644
--- a/boot/i386/pc/boot.S
+++ b/boot/i386/pc/boot.S
@@ -425,7 +425,7 @@ notification_string: .asciz "GRUB "
geometry_error_string: .asciz "Geom"
hd_probe_error_string: .asciz "Hard Disk"
read_error_string: .asciz "Read"
-general_error_string: .asciz " Error"
+general_error_string: .asciz " Error\r\n"
/*
* message: write the string pointed to by %si
_______________________________________________
Grub-devel mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/grub-devel