On Wed, 2 Dec 2020 18:56:46 +0100 Daniel Kiper <[email protected]> wrote:
> On Fri, Nov 27, 2020 at 03:03:37AM -0600, Glenn Washburn wrote: > > We need to convert the sectors from the size of the underlying > > device to the cryptodisk sector size; segment.size is in bytes > > which need to be converted to cryptodisk sectors as well. And > > counter-intuitively, grub_disk_get_size returns the total number of > > device native sectors. > > Should not we change the name to, e.g., grub_disk_native_sectors() > then? Could you do that? Sure, I can do that. > > Also, removed an empty statement. > > > > Signed-off-by: Glenn Washburn <[email protected]> > > Otherwise Reviewed-by: Daniel Kiper <[email protected]> > > Daniel _______________________________________________ Grub-devel mailing list [email protected] https://lists.gnu.org/mailman/listinfo/grub-devel
