>
>
> {
> - ret = (cargs->search_uuid != NULL && grub_strcasecmp
> (cargs->search_uuid, dev->uuid) == 0);
> + ret = cargs->search_uuid && !grub_uuidcasecmp(cargs->search_uuid,
> dev->uuid, sizeof(dev->uuid));
>Please keep comparison with == 0 explicit. Also comparison with NULL improved readability
_______________________________________________ Grub-devel mailing list [email protected] https://lists.gnu.org/mailman/listinfo/grub-devel
