On Sun, Jun 09, 2024 at 03:34:58PM -0400, Patrick Plenefisch wrote:
> This patch isn't necessary by itself, but when combined with the next
> patch it enhances readability as ignored_features_lv is then used for
> multiple types of extra LV's, not just cache LV's
>
> Signed-off-by: Patrick Plenefisch <simonp...@gmail.com>
> ---
>  grub-core/disk/lvm.c | 179 +++++++++++++++++++------------------------
>  1 file changed, 77 insertions(+), 102 deletions(-)
>
> diff --git a/grub-core/disk/lvm.c b/grub-core/disk/lvm.c
> index 794248540..10bc965a4 100644
> --- a/grub-core/disk/lvm.c
> +++ b/grub-core/disk/lvm.c
> @@ -34,12 +34,11 @@
>
>  GRUB_MOD_LICENSE ("GPLv3+");
>
> -struct cache_lv
> +struct ignored_feature_lv
>  {
>    struct grub_diskfilter_lv *lv;
> -  char *cache_pool;

I think this change should go to separate patch as well.
And of course the new patch should have good commit message...

>    char *origin;
> -  struct cache_lv *next;
> +  struct ignored_feature_lv *next;
>  };

Daniel

_______________________________________________
Grub-devel mailing list
Grub-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/grub-devel

Reply via email to