[ https://issues.apache.org/jira/browse/HADOOP-1558?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12515776 ]
Hadoop QA commented on HADOOP-1558: ----------------------------------- +1 http://issues.apache.org/jira/secure/attachment/12362627/hadoop-1558-JUL2607-1600.txt applied and successfully tested against trunk revision r559819. Test results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/471/testReport/ Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/471/console > changes to OutputFormat to work on temporary directory to enable re-running > crashed jobs (Issue: 1121) > ------------------------------------------------------------------------------------------------------ > > Key: HADOOP-1558 > URL: https://issues.apache.org/jira/browse/HADOOP-1558 > Project: Hadoop > Issue Type: Improvement > Components: mapred > Environment: all > Reporter: Alejandro Abdelnur > Fix For: 0.15.0 > > Attachments: hadoop-1558-JUL2607-1600.txt > > > Add OutputFormat methods like: > /** Called to initialize output for this job. */ > void initialize(JobConf job) throws IOException; > /** Called to finalize output for this job. */ > void commit(JobConf job) throws IOException; > In the base implemenation for FileSystem output, initialize() might then > create a temporary directory for the job, removing any that already exists, > and commit could rename the temporary output directory to the final name. > The existing checkOutputSpecs() would continue to throw an exception if the > final output already exists. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online.