Hi Willy,

The simplification makes sense! I don't mind you changing it at all. I really 
appreciate the feedback from you.

Ruei-Bang
________________________________
From: Willy Tarreau <w...@1wt.eu>
Sent: Friday, November 3, 2023 1:50 AM
To: Ruei-Bang Chen <ruec...@linkedin.com>
Cc: haproxy@formilux.org <haproxy@formilux.org>
Subject: Re: [PATCH] MINOR: sample: Add fetcher for getting all cookie names

Hi Ruei-Bang,

On Fri, Nov 03, 2023 at 04:58:36AM +0000, Ruei-Bang Chen wrote:
> Hi Willy and the team,
>
> I just want to send a friendly reminder that I am still looking for feedback
> for this patch.

Thanks!

> I totally understand that there might be other priorities coming up. When you
> get a chance, can you please take a look at the patch from my last email?

While I'm indeed busy on other reviews and bugs in parallel, for this
one I messed up. I can't find your message in my mbox but my logs tell
me it was delivered to the correct box. Thus it looks like a manipulation
error on my side, sorry for this. Anyway I got it from the archives.

Looks good overall, my only comment is this one:

      /* For Set-Cookie, we need to fetch the entire header line (set flag to 
1) */
      if ((is_req && !http_find_header(htx, hdr, &ctx, 0)) ||
          (!is_req && !http_find_header(htx, hdr, &ctx, 1)))
              break;

If you're OK I'll simplify it this way which is much more readable IMHO:

      if (!http_find_header(htx, hdr, &ctx, !is_req))
              break;

Please just let me know if you don't mind me changing it, and I can take
it with today's dev9.

Thanks!
Willy

Reply via email to