>> I don't know about other OSes, but on Windows there 
>> is no distinction between char and string when using 
>> TEXT() macro (it works for both), so IMO it's not 
>> absolutely necessary to match it with type name, since 
>> it will be confusing in places anyway.
> 
> Sorry I do not know what you are talking about.
> 
> Now we do not have type for HBTEXT strings so we have to use locally
> defined workarounds, i.e. in dllpcode.c we have:
> 
>   #if defined( HB_OS_WIN_CE )
>   #  define HBTEXTSTR  LPCTSTR
>   #else
>   #  define HBTEXTSTR  LPCSTR
>   #endif
> 
>   static HBTEXTSTR s_szGetProcAddr = HBTEXT( "_dll_hb_vmProcAddress" );

This is the first time I see these types.
I was talking about TEXT() replacement.

> and I would like to not repeat such declarations in different files
> but rather use everywhere sth like:
> 
>   static const HB_OSCHAR * s_szGetProcAddr = 
>                                       HB_OSTEXT( "_dll_hb_vmProcAddress" );

Anyway, I'm confused now about this matter, so 
can't tell much pro or contra.

First we should define what we're trying to solve.

If this new name for HBTEXT() + type name, above 
is surely better solution, albeit it's used very 
rarely so far.

Brgds,
Viktor

_______________________________________________
Harbour mailing list (attachment size limit: 40KB)
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour

Reply via email to