Jean-Frederic,

This is the area of the code I am working on
fast and furious.  I have used this macro as
a place holder to say, "Stop the world!  It
doesn't work yet!"  I am hoping to get all
of these STUB instances removed in the next
week or so when I get all the code done that
it stubs out.  Any change here will be removed
anyway because the code will be implemented.
If you want to do this locally, it might mean
something to you, but overall, the need for it
will be going away soon.

Dan Lydick


-----Original Message-----
From: Jean-frederic Clere <[EMAIL PROTECTED]>
Sent: Oct 31, 2005 4:47 PM
To: harmony-dev@incubator.apache.org
Subject: [BootJVM] jvm/src/opcode.c patch

Hi,

I would like to propose the following patch:
+++
[EMAIL PROTECTED]:~/harmony/enhanced/trunk/sandbox/contribs/bootjvm/bootJVM> 
svn diff jvm/src/opcode.c
Index: jvm/src/opcode.c
===================================================================
--- jvm/src/opcode.c    (revision 329310)
+++ jvm/src/opcode.c    (working copy)
@@ -985,7 +985,7 @@
  * creating better readability of the code.
  */

-static void dummy1(void) { char *p, *dummy2; dummy2 = p; dummy1(); }
+static void dummy1(void) { void (*p)()=NULL; p(); }
 #define STUB { dummy1(); }

 switch(opcode)
+++
The idea is to core ASAP when we reach a not yet supported opcode, any 
comment?

Cheers

Jean-Frederic




Dan Lydick

Reply via email to