+1 for creating a jdktools directory.  The dependency on the classlib
launcher should be relatively light if we go with a simple tools
launcher that rewrites the tool invocation into a generic launcher
invocation.  You may recall the idea was discussed a while ago.

So, for example,
  jdk/bin/javac -source 1.5 -J-Xmx200M  FooBar
is rewritten to
  jdk/jre/bin/java -cp jdk/lib/tools.jar;jdk/lib/ecj.jar -Xmx200M
org.apache.harmony.tools.javac.Main -source 1.5 FooBar

and so on.

Regards,
Tim

Geir Magnusson Jr. wrote:
> Geir Magnusson Jr. wrote:
>> Now that we have javac, javah, javap (if Tim votes ;) and keytool, I'd
>> like to organize these and add them to the next snapshot.
> 
> My bad - the javap isn't being voted on yet.  I was thinking of the jdwp
> vote... sorry
> 
>>
>> So I propose adding a new top-level directory called "jdktools" (and
>> rename "tools" to "project_tools") and create a build target that -
>> with a  dependency on classlib for the launcher - creates the 'stuff'
>> needed to fill into the JDK.
>>
>> Any comments?
>>
>> geir
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: [EMAIL PROTECTED]
>> For additional commands, e-mail: [EMAIL PROTECTED]
>>
> 
> 
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]
> 
> 

-- 

Tim Ellison ([EMAIL PROTECTED])
IBM Java technology centre, UK.

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to