Dan Weston wrote:
> I like that name, and will henceforth use it myself until someone sees 
> fit to add it to the Prelude!

Oh, and I guess we'd also need:

genericIterateN :: (a -> a) -> Integer -> a -> a

Which also got me thinking, wouldn't it make more sense to have the
count as the first parameter?

iterateN        :: Int -> (a -> a) -> a -> a
genericIterateN :: Integer -> (a -> a) -> a -> a

Cheers,
Maxime
_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

Reply via email to