[ https://issues.apache.org/jira/browse/HDFS-543?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Hairong Kuang updated HDFS-543: ------------------------------- Attachment: writeToReplica2.patch This patch incorporates comments 1 and 4. I also changed TestDataNodeRestart, which was committed in HDFS-544, to use junit4. For comment 2, the constructor is used in Reflection so can not be removed. For comment 3, I took a quick look, it seems not trivial to remove those variables. Not sure if this is a programming bug or simply bad style. I will leave them there for now. > Break FSDatasetInterface#writeToBlock() into writeToTemporary, writeToRBW, > and append > ------------------------------------------------------------------------------------- > > Key: HDFS-543 > URL: https://issues.apache.org/jira/browse/HDFS-543 > Project: Hadoop HDFS > Issue Type: Sub-task > Components: data-node > Affects Versions: Append Branch > Reporter: Hairong Kuang > Assignee: Hairong Kuang > Fix For: Append Branch > > Attachments: writeToReplica.patch, writeToReplica1.patch, > writeToReplica2.patch > > > FSDatasetInterface#writeToBlock() currently allows to create/recover a > temporary replica, create/recover a RBW replica, or append to a replica. The > implementation of the method in FSDataset is very complicated and error > prone. I'd like to break this method into 3: > 1. writeToTemporary allows to create a Temporary replica or recover from a > packet error for a Tempoary replica; > 2. writeToRBW allows to create a RBW replica or recover from a packet error > for a RBW replica; > 3. append allows to append to an existing Finalized replica. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online.