[ 
https://issues.apache.org/jira/browse/HDFS-592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12755816#action_12755816
 ] 

Kan Zhang commented on HDFS-592:
--------------------------------

> If you still do not like the name, could we resolve the naming issue later?
Well, I have said enough on this. It's your call. 

I have a further comment on the following lease checking. It seems if the 
client sends NULL for clientName, the checking is bypassed, which could become 
a security loophole.
{code}
+    if (clientName != null && !pendingFile.getClientName().equals(clientName)) 
{
+      throw new LeaseExpiredException("Lease mismatch: " + block + " owned by "
+          + pendingFile.getClientName() + " but is accessed by " + clientName);
+    }
{code}

> Allow client to get a new generation stamp from NameNode
> --------------------------------------------------------
>
>                 Key: HDFS-592
>                 URL: https://issues.apache.org/jira/browse/HDFS-592
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: name-node
>    Affects Versions: Append Branch
>            Reporter: Hairong Kuang
>            Assignee: Hairong Kuang
>             Fix For: Append Branch
>
>         Attachments: newGS.patch, newGS1.patch, newGS2.patch
>
>
> This issue aims to  add an API to ClientProtocol that fetches a new 
> generation stamp and an access token from NameNode to support append or 
> pipeline recovery.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to