[ 
https://issues.apache.org/jira/browse/HDFS-7888?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14391168#comment-14391168
 ] 

Jing Zhao commented on HDFS-7888:
---------------------------------

Thanks for working on this, Bo. The patch looks good to me. Some minors:
# how about using {{getSimpleName}} here?
{code}
+    String path = this.getClass().getName();
+    String className = path.substring(path.lastIndexOf('.') + 1);
     TraceScope scope =
-        dfsClient.getPathTraceScope("DFSOutputStream#writeChunk", src);
+        dfsClient.getPathTraceScope(className + "#writeChunk", src);
{code}
# {{encounterBlockBoundary}} may not be an appropriate method name. maybe we 
can rename it to something like {{endBlock}}?

> Change DataStreamer/DFSOutputStream/DFSPacket for convenience of subclassing
> ----------------------------------------------------------------------------
>
>                 Key: HDFS-7888
>                 URL: https://issues.apache.org/jira/browse/HDFS-7888
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Li Bo
>            Assignee: Li Bo
>         Attachments: HDFS-7888-001.patch, HDFS-7888-trunk-001.patch, 
> HDFS-7888-trunk-002.patch
>
>
> HDFS-7793 refactors class {{DFSOutputStream}} on trunk which makes 
> {{DFSOutputStream}} a class without any inner classes. We want to subclass 
> {{DFSOutputStream}} to support striping layout writing. This JIRA depends 
> upon HDFS-7793 and tries to change DataStreamer/DFSOutputStream/DFSPacket for 
> convenience of subclassing.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to