[ 
https://issues.apache.org/jira/browse/HDFS-8622?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14662749#comment-14662749
 ] 

Akira AJISAKA commented on HDFS-8622:
-------------------------------------

Thank you for the update. Some comments from me. (Mainly naming of the 
variables)
{code}
      Path parentDir = new Path("/dir1");
{code}
1. I'm thinking the name of the variables should be the same as the name of the 
path for readability.

{code}
      Path targetDirForLinks = new Path("/targetDirForLinks");
{code}
2. Since the directory is not a target of a symlink, dirForLinks is better for 
me.

{code}
      Path linkPath = new Path("/link1");
      Path linkPathDir = new Path("/linkdir");
      Path linkForDir = new Path("/targetDirForLinks/linkfordir1");
{code}
3. I'm thinking linkPathDir and the related test is not necessary because the 
attribute of the target of a symlink is not related to the content summary of 
the symlink. For the naming, link1, link2, ... is sufficient for me.

{code}
      try (FSDataOutputStream o = hdfs.create(new Path(parentDir, "file4"))) {
        o.write("123".getBytes());
      }
      Path filePath = new Path(parentDir,"/file4");
...
      hdfs.createSymlink(filePath, linkPath, true);
{code}
4. We can define the {{filePath}} first and re-use it, or we can create a 
symlink to file1 instead of defining {{filePath}}. The latter option is clear 
for me.

5. Would you fix the checkstyle issue?

> Implement GETCONTENTSUMMARY operation for WebImageViewer
> --------------------------------------------------------
>
>                 Key: HDFS-8622
>                 URL: https://issues.apache.org/jira/browse/HDFS-8622
>             Project: Hadoop HDFS
>          Issue Type: New Feature
>            Reporter: Jagadesh Kiran N
>            Assignee: Jagadesh Kiran N
>         Attachments: HDFS-8622-00.patch, HDFS-8622-01.patch, 
> HDFS-8622-02.patch, HDFS-8622-03.patch, HDFS-8622-04.patch, 
> HDFS-8622-05.patch, HDFS-8622-06.patch, HDFS-8622-07.patch, HDFS-8622-08.patch
>
>
>  it would be better for administrators if {code} GETCONTENTSUMMARY {code} are 
> supported.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to