[ 
https://issues.apache.org/jira/browse/HDFS-9349?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14999641#comment-14999641
 ] 

Mingliang Liu commented on HDFS-9349:
-------------------------------------

The v2 patch looks good overall to me.

Further minor comments:
{code}
-  private final SortedSet<String> protectedDirectories;
+  private SortedSet<String> protectedDirectories;
{code}
Seems we can keep the {{protectedDirectories}} final as we clear/addAll instead 
of constructing a new set when re-configurating it.

{code}
+  void setProtectedDirectories(String dirString) {
{code}
Some java doc may be helpful. And {{dirString}} parameter can be renamed 
{{protectedDirsString}} or...?

> Reconfigure NN protected directories on the fly
> -----------------------------------------------
>
>                 Key: HDFS-9349
>                 URL: https://issues.apache.org/jira/browse/HDFS-9349
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Xiaobing Zhou
>            Assignee: Xiaobing Zhou
>         Attachments: HDFS-9349.001.patch, HDFS-9349.002.patch
>
>
> This is to reconfigure
> {code}
> fs.protected.directories
> {code}
> without restarting NN.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to