Nemo Chen created HDFS-10751:
--------------------------------

             Summary: Log refactoring: method invocation should be replaced by 
a shorter method
                 Key: HDFS-10751
                 URL: https://issues.apache.org/jira/browse/HDFS-10751
             Project: Hadoop HDFS
          Issue Type: Bug
    Affects Versions: 2.7.2
            Reporter: Nemo Chen


Similar to the fix for AVRO-115. In file:

hadoop-rel-release-2.7.2/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/OpenFileCtxCache.java

in line 72, the logging code:
{code:borderStyle=solid}
LOG.trace("openFileMap size:" + openFileMap.size());
{code}
In the same class, there is a method in line 189:
{code:borderStyle=solid}
  int size() {
    return openFileMap.size();
  }
{code}


We can tell that openFileMap.size() could be replaced by  method size() for the 
case of readability and simplicity



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to