[ 
https://issues.apache.org/jira/browse/HDFS-11493?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16061514#comment-16061514
 ] 

Xiaoyu Yao commented on HDFS-11493:
-----------------------------------

Thanks [~anu] for updating the patch. The patch looks pretty good to me. Here 
are my comments:

*HadoopExecutors.java*
Line 104-133
Should we reuse the existing one in 
ShutdownThreadsHelper.shutdownExecutorService?

*ScmConfigKeys.java*
Line 177: NIT: Dont -> Don’t

Line 186: Can we add some document on the other two configuration keys 
introduced? 

*OzoneConfigKeys.java*
NIT: Line 102-105 empty change


*ContainerReplicationManager.java*

Line 109: maxContainerReportThreads can be a local variable.

Line 133: NIT: javadoc incomplete

Line 191-199: this can be pulled into a generic CollectionUtil if it does not 
exist in hadoop-common/hadoop-hdfs

Line 201: conf parameter can be removed as it is not used

Line 216: let’s change the log level to debug to avoid flooding the scm log.

Line 244-249: could this cause infinite loop when hitting unexpected 
exceptions. Can we have a counter to limit the
number of time we will retry starting poolProcessThread? Also, adding a counter 
as you mentioned in the TODO is a good
idea? Can we open a follow up JIRA on that?


Line 289: NIT: we can remove some of the javadocs on streams as they don’t 
apply here.



*InProgressPools.java*

Should we rename it to InProgressPool if this is for a single pool being 
processed?

Line 116: should we change “<“ to “>” to indicate that we have done waiting for 
the maxWaitTime?

Line 207-228: one UNKNOWN node in the pool can cost 100s. Should we reduce the 
maxTry from 1000 to 100 here?


*SCMNodeManager.java*

Line 405: missing /Unknown


*ReplicationDatanodeStateManager.java*
Line 78-81: do we miss the size/keycount for the ContainerInfo of the 
ContainerReport?



> Ozone: SCM:  Add the ability to handle container reports 
> ---------------------------------------------------------
>
>                 Key: HDFS-11493
>                 URL: https://issues.apache.org/jira/browse/HDFS-11493
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>    Affects Versions: HDFS-7240
>            Reporter: Anu Engineer
>            Assignee: Anu Engineer
>         Attachments: container-replication-storage.pdf, 
> exploring-scalability-scm.pdf, HDFS-11493-HDFS-7240.001.patch, 
> HDFS-11493-HDFS-7240.002.patch, HDFS-11493-HDFS-7240.003.patch, 
> HDFS-11493-HDFS-7240.004.patch
>
>
> Once a datanode sends the container report it is SCM's responsibility to 
> determine if the replication levels are acceptable. If it is not, SCM should 
> initiate a replication request to another datanode. This JIRA tracks how SCM  
> handles a container report.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to