[ 
https://issues.apache.org/jira/browse/HDFS-12851?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16263103#comment-16263103
 ] 

Tsz Wo Nicholas Sze commented on HDFS-12851:
--------------------------------------------

Thanks, Mukul.  Patch looks good.  Some minor comments:
- Set rpc type in RatisHelper.newRaftClient
{code}
    RaftConfigKeys.Rpc.setType(properties, rpcType);
{code}
- In order to avoid hard coding the key names, use RaftServerConfigKeys and 
GrpcConfigKeys in XceiverServerRatis.newRaftProperties as above.
- Rename startNanos to startMillis since Time.monotonicNow() returns 
milliseconds.


> Ozone: Upgrade to latest ratis build
> ------------------------------------
>
>                 Key: HDFS-12851
>                 URL: https://issues.apache.org/jira/browse/HDFS-12851
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>    Affects Versions: HDFS-7240
>            Reporter: Mukul Kumar Singh
>            Assignee: Mukul Kumar Singh
>             Fix For: HDFS-7240
>
>         Attachments: HDFS-12851-HDFS-7240.001.patch, 
> HDFS-12851-HDFS-7240.002.patch
>
>
> Ratis build on Ozone needs to be upgraded to incorporate memory leak 
> fixes(RATIS-135, RATIS-116), state machine optimization(RATIS-122) and Async 
> client api (RATIS-113)



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to