[ 
https://issues.apache.org/jira/browse/HDFS-13912?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16674710#comment-16674710
 ] 

Dibyendu Karmakar commented on HDFS-13912:
------------------------------------------

I am in favor of making the update command a little bit more flexible. The 
destination field in the updated command become unnecessary if we are updating 
other attributes (order, mode etc.) not the destination. 
 I would prefer the behavior like:
{code:java}
hdfs dfsrouteadmin -update /mnt -dest ns /target /* to update destination field 
*/
similarly,
hdfs dfsrouteadmin -update /mnt -order RANDOM /* to update order field */ and 
so on..
{code}
 and we should also have a functionality like
  
{code:java}
hdfs dfsrouteadmin -update /mnt -removeDest ns /target /* to remove existing 
destination field */
hdfs dfsrouteadmin -update /mnt -addDest ns /target /* to add new destination 
field in existing mount entry*/
{code}
To do this if we create separate methods for each field, that will include 
similar code and increase the code size.

If we can modify the existing update command then that will be a better option. 
This also depends on individual preference. If all agree, we can modify the 
existing command otherwise we can have separate command/method for each field.

[~elgoiri], 
{quote}at some point I may even want to provide a FileSystem interface for this 
and be able to do stuff like:
{code:java}
hdfs dfs -chown user1 mount://mnt1{code}
Even we could just capture these methods in RouterClientProtocol.
{quote}
I didn't get your point but I think mixing admin operations with filesystem 
interface will create confusions. IMO separate interface for admin operations 
is better.

> RBF: Add methods to RouterAdmin to set order, read only, and chown
> ------------------------------------------------------------------
>
>                 Key: HDFS-13912
>                 URL: https://issues.apache.org/jira/browse/HDFS-13912
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Ayush Saxena
>            Assignee: Ayush Saxena
>            Priority: Major
>         Attachments: HDFS-13912-01.patch, HDFS-13912-02.patch
>
>
> Presently there is methods for only quotas for an existing mount entries.
> Similarly it can be added for the other remaining parameters those even are 
> dynamic and requires changes. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to