[ 
https://issues.apache.org/jira/browse/HDDS-795?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16691693#comment-16691693
 ] 

Elek, Marton commented on HDDS-795:
-----------------------------------

Thanks the review [~ajayydv]

bq. DBStore

I fixed all the javadocs. + I removed the throw tag from the javadoc instead of 
adding to the method signature as it's not necessary for creating a new batch.

bq. BatchOperation: Should this have api for commit op as well?

It's part of the DBStore interface (void commitBatchOperation(BatchOperation 
operation) throws IOException;). BatchOperation is just a generic holder which 
can include all the required operations to commit.

bq. Table / Rename new put operation to "addToBatch"

Can't use this name exactly, as I have both put and delete operations with and 
without batch batch support. I need two new names.

But I understand your comment that the names of method with/without batch 
support should be more different. (I agree, it would be more understandable 
from the code).

I renamed them to deleteWithBatch and putWithBatch. Let me know if you have 
better name suggestions (but I need two new names which are operation specific)

bq: Unused imports ...

It was not detected by jenkins neither by my IDE. But during a rebase to trunk 
I saw import related conflicts. They should be disappeared with the rebase. 

bq. TestRDBTableStore L169 / L190

The additional assertions are added, thanks.

> RocksDb specific classes leak from DBStore/Table interfaces
> -----------------------------------------------------------
>
>                 Key: HDDS-795
>                 URL: https://issues.apache.org/jira/browse/HDDS-795
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>            Reporter: Elek, Marton
>            Assignee: Elek, Marton
>            Priority: Major
>         Attachments: HDDS-795.001.patch, HDDS-795.002.patch, 
> HDDS-795.003.patch, HDDS-795.004.patch
>
>
> org.apache.hadoop.utils.db.RocksDB and Table interfaces provide a 
> vendor-independent way to access any key value store. 
> The default implementation uses RocksDb but other implementation also could 
> be used (for example an InMemory implementation for testing only).
> The current Table interface contains methods which depend on RocksDB specific 
> classes. For example:
> {code}
> public interface DBStore extends AutoCloseable {
> //...
> /**
>    * Return the Column Family handle. TODO: This leaks an RockDB abstraction
>    * into Ozone code, cleanup later.
>    *
>    * @return ColumnFamilyHandle
>    */
>   ColumnFamilyHandle getHandle();
> //...
> {code}
> We need to remove the RocksDB specific classes from the generic interfaces.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to