[ 
https://issues.apache.org/jira/browse/HDDS-870?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16705973#comment-16705973
 ] 

Mukul Kumar Singh commented on HDDS-870:
----------------------------------------

Thanks for updating the patch [~shashikant]. The v3 patch looks good to me. 
Some minor comments.

1) ChunkGroupOutputStream#373, computeBufferData is being called write, the 
value can be cached once. also bufferedData should be renamed to something like 
bufferedDataLen.
2) ChunkGroupOutputStream#265, the parallel Stream should be changed to use 
just stream. Also the function can be changed to return an int.
3) ChunkGroupOutputStream#304-> info level logs to debug, also the comments 
here needs to be changed as well to point to current
4) ChunkGroupOutputStream,382, this code should be moved before handleWrites, 
as during handleWrites, new block will be allocated and added to streamEntries, 
one of these blocks can be removed mistakenly here.
5) ChunkGroupOutputStream:511, parallelStream to stream
6) ChunkOutputStream#159, the buffer should not be allocated everytime, on 
retries when the already buffered data is being re-used. 


> Avoid creating block sized buffer in ChunkGroupOutputStream
> -----------------------------------------------------------
>
>                 Key: HDDS-870
>                 URL: https://issues.apache.org/jira/browse/HDDS-870
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>          Components: Ozone Client
>    Affects Versions: 0.4.0
>            Reporter: Shashikant Banerjee
>            Assignee: Shashikant Banerjee
>            Priority: Major
>             Fix For: 0.4.0
>
>         Attachments: HDDS-870.000.patch, HDDS-870.001.patch, 
> HDDS-870.002.patch, HDDS-870.003.patch
>
>
> Currently, for a key, we create a block size byteBuffer in order for caching 
> data. This can be replaced with an array of buffers of size flush buffer size 
> configured for handling 2 node failures as well.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to