[ 
https://issues.apache.org/jira/browse/HDDS-1233?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Aravindan Vijayan updated HDDS-1233:
------------------------------------
    Attachment: HDDS-1233-002.patch
        Status: Patch Available  (was: Open)

Thanks for the review [~swagle] and [~linyiqun]. 

Addressed Review comments

* "recon.om.connection.timeout", specify millis, same for other configs - 
*Fixed*
* ReconUtils seems to provide configuration key, should probably be named 
appropriately - *Added more methods here. So, the class name now makes sense. *
* untarCheckpointFile, increase READ/WRITE buffer sizes. - Increased to 50Kb.
* Don't see the need for ReconOMMetadataManagerProvider. - *Removed*
* ReconContainerDBProvider might return null - *No straightforward way to fix 
this since RocksDB constructor itself throws IOException. We can revisit this 
later. *
* omMetadataManager.start(configuration) Should rename if it does not start a 
thread - *Fixed*

OzoneManagerServiceProviderImpl
Line 98: Format string lacks one '{}' -
Line 78: We can make these time configs support with time-unit suffixes. Like 
ozone.om.save.metrics.interval did. After that, we should use 
Configuration#getTimeDuration to get the value.
*Fixed both*

ReconOMHelper
Line 215: The GzipCompressorInputStream should be closed before throwing the 
exception, otherwise it will lead the resource leak.
*Fixed*

OMConfigKeys
Line 56: This setting is existed in OzoneConfigKeys#OZONE_SECURITY_ENABLED_KEY 
under hadoop-hdds-common.
*Fixed*

Unit test
Can we add the prefix 'test'}}for all added test cases (exclude setup/teardown 
method)? E.g. {{getOMMetadataManagerInstance to 
testGetOMMetadataManagerInstance.
*Fixed*

> Create an Ozone Manager Service provider for Recon.
> ---------------------------------------------------
>
>                 Key: HDDS-1233
>                 URL: https://issues.apache.org/jira/browse/HDDS-1233
>             Project: Hadoop Distributed Data Store
>          Issue Type: Sub-task
>          Components: Ozone Recon
>            Reporter: Aravindan Vijayan
>            Assignee: Aravindan Vijayan
>            Priority: Major
>             Fix For: 0.5.0
>
>         Attachments: HDDS-1233-000.patch, HDDS-1233-001.patch, 
> HDDS-1233-002.patch
>
>
> * Implement an abstraction to let Recon make OM specific requests.
> * At this point of time, the only request is to get the DB snapshot. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to