[ 
https://issues.apache.org/jira/browse/HDDS-1234?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16798392#comment-16798392
 ] 

Siddharth Wagle commented on HDDS-1234:
---------------------------------------

- _scheduleReconTasks(Injector injector)_: Injector passed down as a parameter 
is a bit of an anti-pattern. Instead, use field injection or injected 
constructor to create immutable objects.
- getCountForForContainerKeyPrefix(): For readability, Integer.valueOf(0)
- getKeyPrefixesForContainer# 145: Seems null check should be needed, 
containerIterator.next().getKey()
- ContainerKeyMapperTask(): Dependencies could be injected here.
- <minor> TestHelper: suggest reame to TestReconOMHelper 
- <minor> Instead of TestHelper defining static methods, I would create a base 
abstract class that hides behavior of creating temp location and db completely.

> Iterate the OM DB snapshot and populate the recon container DB. 
> ----------------------------------------------------------------
>
>                 Key: HDDS-1234
>                 URL: https://issues.apache.org/jira/browse/HDDS-1234
>             Project: Hadoop Distributed Data Store
>          Issue Type: Sub-task
>          Components: Ozone Recon
>            Reporter: Aravindan Vijayan
>            Assignee: Aravindan Vijayan
>            Priority: Major
>             Fix For: 0.5.0
>
>         Attachments: HDDS-1234-000.patch, HDDS-1234-001.patch
>
>
> * OM DB snapshot contains the Key->ContainerId + BlockId information. 
> * Iterate the OM snapshot DB and create the reverse map of (ContainerId, Key 
> prefix) -> Key count to be stored in the Recon container DB.
> * Use a codec to store data into Recon container DB.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to