[ 
https://issues.apache.org/jira/browse/HDFS-15767?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17268148#comment-17268148
 ] 

Íñigo Goiri commented on HDFS-15767:
------------------------------------

Thanks [~LiJinglun] for the updates.
The overall structure looks pretty good.
I would try to work on readability and operation now.
* Fix the config unit test.
* enableRenameAcrossNamespace() should be isEnabledRenameAcrossNamespace().
* We should add metrics and possibly a way to monitor the rename operations 
going on (possibly a follow-up UI change too).
* The parameters of buildRouterRenameJob() could be nsId and path instead of 
path so we build the Path inside.
* I would expand the check for the parameters negative in 
buildRouterRenameJob().
* The building of the FedBalanceContext might be good to have the sets in each 
line.
* The logging of the context in buildRouterRenameJob() could be a little 
friendlier.
* initRouterFedRename() could check the negative case first and return.
* I'd like a few comments in initRouterFedRename() explaining specially the 
port and host paths.

> RBF: Router federation rename of directory.
> -------------------------------------------
>
>                 Key: HDFS-15767
>                 URL: https://issues.apache.org/jira/browse/HDFS-15767
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Jinglun
>            Assignee: Jinglun
>            Priority: Major
>         Attachments: HDFS-15767.001.patch, HDFS-15767.002.patch, 
> HDFS-15767.003.patch
>
>
> This Jira trys to support rename of directory across namespaces using 
> fedbalance framework. 
> We can do the router federation rename when:
>  # Both the src and dst has only one remote location.
>  # The src and dst remote locations are at different namespaces.
>  # The src is a directory.(Fedbalance depends on snapshot).
>  # The dst doesn't exist.
> We can implement router federation rename of file in a new task so the patch 
> won't be too big to review.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to