[ 
https://issues.apache.org/jira/browse/HDFS-16709?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17576956#comment-17576956
 ] 

Ayush Saxena commented on HDFS-16709:
-------------------------------------

Committed to trunk.

Thanx [~xuzq_zander] for the contribution!!!

> Remove redundant cast in FSEditLogOp.class
> ------------------------------------------
>
>                 Key: HDFS-16709
>                 URL: https://issues.apache.org/jira/browse/HDFS-16709
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: ZanderXu
>            Assignee: ZanderXu
>            Priority: Major
>              Labels: pull-request-available
>          Time Spent: 50m
>  Remaining Estimate: 0h
>
> When I read some class about Edits of NameNode, I found that there are much 
> redundant cast inĀ FSEditLogOp.class, I feel that we should remove them.
> Such as:
> {code:java}
> static UpdateBlocksOp getInstance(OpInstanceCache cache) {
>   return (UpdateBlocksOp)cache.get(OP_UPDATE_BLOCKS);
> } {code}
> Because cache.get() have cast the response to T, such as:
> {code:java}
> @SuppressWarnings("unchecked")
> public <T extends FSEditLogOp> T get(FSEditLogOpCodes opCode) {
>   return useCache ? (T)CACHE.get().get(opCode) : (T)newInstance(opCode);
> } {code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to