[ 
https://issues.apache.org/jira/browse/HDFS-2887?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13203941#comment-13203941
 ] 

Suresh Srinivas commented on HDFS-2887:
---------------------------------------

Change make the code much cleaner. Comments:
# Currently there are several places in FSVolumeSet where FSVolumeInterface is 
cast to FSVolume. FSVolumeSet should continue to take FSVolume in the 
constructor. That way outside FSDataset the only thing exposed is 
FSVolumeInterface. Inside FSDataset, we could continue to use FSVolume?
# In a separate Jira perhaps we should add to FSDatasetInterface, 
isDataScanSupported() and isDirectoryScanSupported. Perhaps we could move 
scanners starting to FSDataset altogether and add a method, startScanners()?
# When committing this change, this should be marked incompatible, due to 
BlockVolumeChoosingPolicy change

                
> Define a FSVolume interface
> ---------------------------
>
>                 Key: HDFS-2887
>                 URL: https://issues.apache.org/jira/browse/HDFS-2887
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h2887_20120203.patch, h2887_20120207.patch
>
>
> FSVolume is an inner class in FSDataset.  It is actually a part of the 
> implementation of FSDatasetInterface.  It is better to define a new 
> interface, namely FSVolumeInterface, to capture the abstraction.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to