[ 
https://issues.apache.org/jira/browse/HDFS-3492?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13291543#comment-13291543
 ] 

Hadoop QA commented on HDFS-3492:
---------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12531333/HDFS-3492.002.patch
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 2 new or modified test 
files.

    +1 javac.  The applied patch does not increase the total number of javac 
compiler warnings.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) 
warnings.

    +1 release audit.  The applied patch does not increase the total number of 
release audit warnings.

    -1 core tests.  The patch failed these unit tests in 
hadoop-hdfs-project/hadoop-hdfs hadoop-hdfs-project/hadoop-hdfs-httpfs:

                  
org.apache.hadoop.hdfs.server.namenode.metrics.TestNameNodeMetrics
                  org.apache.hadoop.hdfs.server.datanode.TestBPOfferService
                  org.apache.hadoop.test.TestHFSTestCase
                  org.apache.hadoop.test.TestHTestCase

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: 
https://builds.apache.org/job/PreCommit-HDFS-Build/2617//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2617//console

This message is automatically generated.
                
> fix some misuses of InputStream#skip
> ------------------------------------
>
>                 Key: HDFS-3492
>                 URL: https://issues.apache.org/jira/browse/HDFS-3492
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>            Priority: Minor
>         Attachments: HDFS-3492.001.patch, HDFS-3492.002.patch
>
>
> It seems that we have a few cases where programmers are calling 
> InputStream#skip and not handling "short skips."  Unfortunately, the skip 
> method is documented and implemented so that it doesn't actually skip the 
> requested number of bytes, but simply tries to skip at most that amount of 
> bytes.  A better name probably would have been trySkip or similar.
> It seems like most of the time when the argument to skip is small enough, 
> we'll succeed almost all of the time.  This is no doubt an implementation 
> artifact of some of the popular stream implementations.  This tends to hide 
> the bug-- however, it is still waiting to emerge at some point if those 
> implementations ever change or if buffer sizes are adjusted, etc.
> All of these cases can be fixed by calling IOUtils#skipFully to get the 
> behavior that the programmer expects-- i.e., skipping by the specified amount.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to