[ 
https://issues.apache.org/jira/browse/HDFS-4434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13623123#comment-13623123
 ] 

Brandon Li commented on HDFS-4434:
----------------------------------

The patch looks good. There are some comments:
{noformat}
1. HdfsConstants.java has no real code change. Please revert it.
2. some Java version(e.g.,1.6) doesn't allow @Override on interface methods. So 
it's safer for now to remove @Override from FSNamesystem.checkOperation()
3. There is no .inodes path resolution for FSNamesystem.getBlockLocations()
4. DFS_NAMENODE_SUPPORT_FILEID_MAP_KEY seems to be a better name than 
DFS_NAMENODE_SUPPORT_FILEID_KEY.
5. in FSDirectory.addInode(): combine these two lines:
      boolean ret = addLastINode(inodesInPath, child, true);
      return ret;
6. update comment FSDirectory.resolvePath() for "/.reserved"
7. a bug in FSDirectory.resolvePath(): it should be "||" instead of "&&"
    // Not /.reserved/.abc
    if (!Arrays.equals(DOT_RESERVED, pathComponents[1])
        && !Arrays.equals(DOT_INODES, pathComponents[2])) { // Not .inodes path
      return src;
    }
{noformat}
                
> Provide a mapping from INodeId to INode
> ---------------------------------------
>
>                 Key: HDFS-4434
>                 URL: https://issues.apache.org/jira/browse/HDFS-4434
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: 3.0.0
>            Reporter: Brandon Li
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-4434.patch, HDFS-4434.patch, HDFS-4434.patch, 
> HDFS-4434.patch, HDFS-4434.patch, HDFS-4434.patch, HDFS-4434.patch, 
> HDFS-4434.patch, HDFS-4434.patch, HDFS-4434.patch, HDFS-4434.patch
>
>
> This JIRA is to provide a way to access the INode via its id. The proposed 
> solution is to have an in-memory mapping from INodeId to INode. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to