[ 
https://issues.apache.org/jira/browse/HDFS-6561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14097901#comment-14097901
 ] 

Colin Patrick McCabe commented on HDFS-6561:
--------------------------------------------

So, I think that we could refactor this to be nicer.  I think we really don't 
need the boolean everywhere, but we could refactor things into utility 
functions and two separate code paths.  This would also gain back that tiny bit 
of performance.

But, that might involve a lot more work, so I'm ok with combining the code 
paths for now.  In view of Todd's results, there's shouldn't be any significant 
performance regression.  We can always split them later.

{code}
-    if (unlikely(crc != *sums)) {
+    if (unlikely(!store_or_verify(sums, crc, is_verify)))
       goto return_crc_error;
-    }
{code}

Let's not get rid of the braces here.

+1 once that's addressed.  Thanks, James.

> Byte array native checksumming on client side
> ---------------------------------------------
>
>                 Key: HDFS-6561
>                 URL: https://issues.apache.org/jira/browse/HDFS-6561
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, hdfs-client, performance
>            Reporter: James Thomas
>            Assignee: James Thomas
>         Attachments: HDFS-6561.2.patch, HDFS-6561.3.patch, HDFS-6561.4.patch, 
> HDFS-6561.patch, hdfs-6561-just-hadoop-changes.txt
>
>




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to