[ 
https://issues.apache.org/jira/browse/HIVE-1096?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

John Sichi updated HIVE-1096:
-----------------------------

    Status: Open  (was: Patch Available)

I'm getting a conflict with latest trunk--can you regenerate the patch?  (Use 
filename HIVE-1096.10.patch to follow the usual convention.)

Sorry it took us so long to get to this one; here are a few review comments to 
be addressed as part of a new patch:

* add a test with a query which references the same variable twice
* add a test which references a built-in variable such as hive.map.aggr
* add a test with hive.variable.replace=false to verify that expansion does not 
happen when the variable is turned off (reference the variable in a literal 
string)
* add a test which references a variable which has not been set
* for description, change "This setting controls if hive will..." to "Whether 
hive will..."
* rename method to replaceVariableReferences
* for the LOG.info's, add a space after the colon, and change "replacement" to 
"variable replacement" for clarity
* run ant checkstyle and fix some issues with spaces before braces and arglists
* to optimize the replacement, you could do a contains("${") precheck before 
looping over conf
* if you want to allow for uber-cool recursive variable expansion, change if 
(command.contains(s)) to a while instead


> Hive Variables
> --------------
>
>                 Key: HIVE-1096
>                 URL: https://issues.apache.org/jira/browse/HIVE-1096
>             Project: Hadoop Hive
>          Issue Type: New Feature
>            Reporter: Edward Capriolo
>            Assignee: Edward Capriolo
>         Attachments: 1096-9.diff, hive-1096-2.diff, hive-1096-7.diff, 
> hive-1096-8.diff, hive-1096.diff
>
>
> From mailing list:
> --Amazon Elastic MapReduce version of Hive seems to have a nice feature 
> called "Variables." Basically you can define a variable via command-line 
> while invoking hive with -d DT=2009-12-09 and then refer to the variable via 
> ${DT} within the hive queries. This could be extremely useful. I can't seem 
> to find this feature even on trunk. Is this feature currently anywhere in the 
> roadmap?--
> This could be implemented in many places.
> A simple place to put this is 
> in Driver.compile or Driver.run we can do string substitutions at that level, 
> and further downstream need not be effected. 
> There could be some benefits to doing this further downstream, parser,plan. 
> but based on the simple needs we may not need to overthink this.
> I will get started on implementing in compile unless someone wants to discuss 
> this more.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: 
https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to