On Oct 1, 2010, at 5:56 PM, Skott Klebe wrote:

> 1.  Table-plus column headers don't seem to respect the view-hints for
> column display names.  There's an old ticket for it - 455 - but I'm
> still seeing the behavior in 1.0.1.

Hmmm, that's weird. The code's definitely there in rapid_plus.dryml. Can you 
provide a short example for clarity?

> 2.  Trying to override column headers in DRYML, using the
> #{scope.field_name}-heading syntax.
> First, what's the proper way to identify the column specified as
> "this" in the field_list?  I've tried everything I can think of -
> this-heading, id-heading, name-heading.  Nothing I've thought of seems
> to get recognized as a tag that should replace the default.

'this' is actually specified as the class name of the model (CamelCased and 
all) followed by -heading. This is bad, but is the current behavior. For future 
debugging help, note that most tags will end up with the associated param name 
as a class attribute by default.

> Second, #{scope.field_name}-heading only seems to work on fields that
> are not foreign keys.

I suspect this is related to tickets like #436; can you check what the 
generated class name on one of those <th>s is?

Thanks,

--Matt Jones


-- 
You received this message because you are subscribed to the Google Groups "Hobo 
Users" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to 
[email protected].
For more options, visit this group at 
http://groups.google.com/group/hobousers?hl=en.

Reply via email to