On Jan 19, 2010, at 3:15 PM, Brice Goglin wrote:

> > I say "bytes" instead of "kilobytes" because it might be easier to avoid 
> > getting into the "what does kilo mean -- 1000 or 1024?" arguments.
> 
> kilo mean 1000, otherwise it's called kibi :)

Forgot to mention -- I think that comment proves the point right there.  I 
would have never come up with "kibi" to mean "kilobytes".

> But I am ok with changing all this into bytes or whatever.

Perfect; I think that will be least ambiguous.

> > Or maybe just total and local memory set to 0?
> 
> Don't know. I thought having memory point to NULL when the object can
> obviously contain no memory could help, but it's not a big deal.

Ya, I'm still torn -- on one hand, saving a little memory is a good thing.  On 
the other hand, it's nice to not have to put an "if" in just to calculate how 
much memory you have (i.e., if (ptr) size+=ptr->...).

It might still be nice to have a total_descendants_memory field (or a shorter 
field) that represents the sum of all children memory since it is probably not 
an uncommon action to just want to know how much memory I can access *from this 
point in the hierarchy*.

-- 
Jeff Squyres
jsquy...@cisco.com


Reply via email to