Hi Murray,

actually we do not have a rough consensus regarding Section 3
of RFC 7282.

The architecture of spec-06 is known to be insecure, confirmed by
Bron [1] and Richard [2].

If you or Pete are closing this thread, I will not be available
for review anymore.

Side-note: Pete is able to defend himself.

Regards,
Timo

[1]
https://mailarchive.ietf.org/arch/msg/ietf-dkim/81n06DYR1-8NakXrf89bDorm9mQ/
[2] Message-ID: <[email protected]> in the same
archive thread.

It looks like Murray S. Kucherawy aimed to say:
> On Wed, Sep 16, 2026 at 3:04 AM Timo Gerke <[email protected]> wrote:
>> Sorry, Pete, but regarding <xref target="RFC2026" /> and
>> <xref target="RFC2418" section="2.2" /> this is the duty of the
>> authors and/or editors.
>>
>> I have already provided a complete structural solution:
>> a flattened JSON array layout to eliminate duplicate-key parsing
>> differentials and guarantee predictable linear O(n) parsing time.
>>
>> If the authors refuse to fix a known, structural vulnerability
>> (RFC 8259) in their text, the document lacks the necessary
>> security architecture to achieve consensus. I expect the authors
>> to integrate the flat array framework into the next revision.
> 
> To clarify: It is the duty of the authors/editors to record working
> group consensus (see RFC 2418, Section 6.3).  I do not believe
> consensus has been established around the changes you're proposing.
> 
> I concur with the prior suggestion that providing proposed alternative
> text for the working group to consider would be very helpful here.
> 
> -MSK, DKIM co-chair
> _______________________________________________
> Ietf-dkim mailing list -- [email protected]
> To unsubscribe send an email to [email protected]


Timo Gerke
Hamburg, Germany

"If you think technology can solve your security
 problems then you don't understand the problems
 and you don't understand the technology."
   -- Bruce Schneier

Attachment: OpenPGP_0x9F03DF9F597BF31E.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature.asc
Description: OpenPGP digital signature

_______________________________________________
Ietf-dkim mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to