On 4/27/2017 4:58 PM, Chris Wilson wrote:
On Thu, Apr 27, 2017 at 04:12:52PM -0700, Michel Thierry wrote:
+#define WA_REG_WR_GUC_RESTORE(addr, val) do { \
+               const int r = guc_wa_add(dev_priv, (addr), (val)); \
+               if (r) \
+                       return r; \
+       } while (0)

Try to avoid burying returns inside macros. Does this macro help code
readability? Would perhaps just a table of registers + values be easier?
-Chris


Sure, I can change it to something else.
I only replicated what the other WA_* macros (the ones we need in ctx switch) were doing.
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to