Hi Ville.

On Tue, Jan 29, 2019 at 07:06:09PM +0200, Ville Syrjala wrote:
> From: Ville Syrjälä <ville.syrj...@linux.intel.com>
> 
> drm_color_lut_check() doens't modify the passed in blob so
> let's make it const.
> 
> Also s/uint32_y/u32/ while at it.
> 
> Cc: Matt Roper <matthew.d.ro...@intel.com>
> Signed-off-by: Ville Syrjälä <ville.syrj...@linux.intel.com>
> ---
>  drivers/gpu/drm/drm_color_mgmt.c | 6 +++---
>  include/drm/drm_color_mgmt.h     | 4 ++--
>  2 files changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_color_mgmt.c 
> b/drivers/gpu/drm/drm_color_mgmt.c
> index 968ca7c91ad8..3c8826a91a03 100644
> --- a/drivers/gpu/drm/drm_color_mgmt.c
> +++ b/drivers/gpu/drm/drm_color_mgmt.c
> @@ -474,10 +474,10 @@ EXPORT_SYMBOL(drm_plane_create_color_properties);
>   *
>   * Returns 0 on success, -EINVAL on failure.
>   */
> -int drm_color_lut_check(struct drm_property_blob *lut,
> -                     uint32_t tests)
> +int drm_color_lut_check(const struct drm_property_blob *lut,
> +                     u32 tests)

No need to linewrap this line.
>  {
> -     struct drm_color_lut *entry;
> +     const struct drm_color_lut *entry;
>       int i;
>  
>       if (!lut || !tests)
> diff --git a/include/drm/drm_color_mgmt.h b/include/drm/drm_color_mgmt.h
> index 6affbda6d9cb..58d4b20b5b97 100644
> --- a/include/drm/drm_color_mgmt.h
> +++ b/include/drm/drm_color_mgmt.h
> @@ -96,6 +96,6 @@ enum drm_color_lut_tests {
>       DRM_COLOR_LUT_NON_DECREASING = BIT(1),
>  };
>  
> -int drm_color_lut_check(struct drm_property_blob *lut,
> -                     uint32_t tests);
> +int drm_color_lut_check(const struct drm_property_blob *lut,
> +                     u32 tests);
Likewise.

With the linewrap fixed:
Reviewed-by: Sam Ravnborg <s...@ravnborg.org>

Note: does not apply to my drm-misc tree. Anything I miss here?

        Sam

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to