On Tue, Jan 21, 2014 at 12:33:22PM -0800, Ben Widawsky wrote:
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -1356,6 +1356,18 @@ struct intel_pipe_crc {
>       wait_queue_head_t wq;
>  };
>  
> +struct pipe_crc_info {
> +     const char *name;
> +     struct drm_device *dev;
> +     enum pipe pipe;
> +};
> +
> +extern struct pipe_crc_info i915_pipe_crc_data[I915_MAX_PIPES];
> +extern const struct file_operations i915_display_crc_ctl_fops;
> +
> +int i915_pipe_crc_create(struct dentry *root, struct drm_minor *minor,
> +                      enum pipe pipe);
> +
>  typedef struct drm_i915_private {
>       struct drm_device *dev;
>       struct kmem_cache *slab;

Oops, I think I should have looked at that hunk before, hidden in that
big diff it wasn't obvious.

We try to put display related things into intel_drv.h, it was in
i915_drv.h because it was in debugfs.c. Also intel_drv.h and i915_drv.h
are neatly separated by file, so it'd be nice to have a separate entry
for intel_display_test.c.

Bikeshedding territory, I know, sorry. With that changed or not you have
my: Reviewed-by: Damien Lespiau <damien.lesp...@intel.com>

Who knows Daniel may not insist on this particular OCD.

-- 
Damien
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to