On Wed, 2026-06-10 at 10:20 +0200, Markus Elfring wrote: > From: Markus Elfring <[email protected]> > Date: Wed, 10 Jun 2026 10:02:58 +0200 > > [...] > > diff --git a/drivers/net/ethernet/intel/i40e/i40e_client.c > b/drivers/net/ethernet/intel/i40e/i40e_client.c > index 84a97ca8a6d8..389b8b83afbd 100644 > --- a/drivers/net/ethernet/intel/i40e/i40e_client.c > +++ b/drivers/net/ethernet/intel/i40e/i40e_client.c > @@ -304,15 +304,15 @@ static int i40e_register_auxiliary_dev(struct i40e_info > *ldev, > const char *name) > ldev->aux_dev = aux_dev; > > ret = ida_alloc(&i40e_client_ida, GFP_KERNEL); > - if (ret < 0) { > - kfree(i40e_aux_dev); > - return ret; > - } > + if (ret < 0) > + goto free_aux_dev; > + > aux_dev->id = ret; > > ret = auxiliary_device_init(aux_dev); > if (ret < 0) { > ida_free(&i40e_client_ida, aux_dev->id); > +free_aux_dev: > kfree(i40e_aux_dev); > return ret; why do you do this? There's no functional change, right? is it just readability?
Thanks Manuel
