Hi,

I would suggest another name for ifsetor.

In relational databases, there is a similar function, called NVL in oracle,
and
IFNULL in MySQL and coalesce in postgresql for testing for null, and
returning
a default value if the variable is null.

I think ifsetor sounds a big ugly. I would suggest ifset($var,
$defaultvalue),
as there are historical analogies with mysql's IFNULL function, and i think
ifset looks different enough from isset, thanks to the tall 'F'.

$var = isset($aval) ? $aval : 0;

$var = ifset($aval, 0);

Thanks, John


"Daniel Crookston" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]
> Why not just call it the issetor, or the setor operator?  Also, why does
> www.php.net/ternary not link to what one would assume it might link to?
We
> could do the same with www.php.net/setor.
>
> Dan
>
> > But the fact still remains that if we did go with
> > this syntax, we could and probably should find a name for it.

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to